Author Topic: BASS error -1  (Read 4653 times)

Thomas S.

  • Newbie
  • *
  • Posts: 18
    • View Profile
    • Radio am Niederrhein
    • Email
BASS error -1
« on: January 23, 2010, 14:33:12 »
Hallo liebe User,

bei mairlist build 664 habe ich beim Versuch mit dem icecastserver zu verbinden immer den Fehler  BASS Error -1, habe leider dazu noch nichts gefunden,
was dieses Problem beheben könnte.

Danke für Eure Hilfe

Torben

  • Administrator
  • Doktor mAirList
  • *****
  • Posts: 16287
    • View Profile
Re: BASS error -1
« Reply #1 on: January 24, 2010, 14:41:53 »
Die Fehlermeldung müsste noch einige Angaben mehr enthalten. Poste bitte mal die komplette Meldung.

(Kannst du dir auch aus dem Systemprotokoll kopieren -> Doppelklick auf die Statuszeile im Hauptfenster.)

Thomas S.

  • Newbie
  • *
  • Posts: 18
    • View Profile
    • Radio am Niederrhein
    • Email
Re: BASS error -1
« Reply #2 on: January 25, 2010, 23:38:51 »
leider steht da nicht mehr als dieses:

25.01.2010 23:36:16 Status       Lade Modul MiscDatabases...
25.01.2010 23:36:16 Status       Lade Modul WMClient...
25.01.2010 23:36:16 Status       Lade Modul HTTP...
25.01.2010 23:36:16 Status       Lade Modul InpOut32...
25.01.2010 23:36:16 Status       Lade Modul AudioFileTypes...
25.01.2010 23:36:16 Status       Lade Modul audimark...
25.01.2010 23:36:16 Status       Starte Engine...
25.01.2010 23:36:16 Status       Initialisiere Player...
25.01.2010 23:36:16 Status       Initialisiere Cartwall...
25.01.2010 23:36:22 Information  Encoder verbindet...
25.01.2010 23:36:48 Fehler       Fehler beim Verbinden mit dem Streamingserver: BASS error -1
25.01.2010 23:36:48 Fehler       Fehler beim Verbinden mit dem Streamingserver: BASS error -1
25.01.2010 23:38:08 Fehler       Fehler beim Verbinden mit dem Streamingserver: BASS error -1
« Last Edit: January 25, 2010, 23:40:33 by Thomas S. »

Torben

  • Administrator
  • Doktor mAirList
  • *****
  • Posts: 16287
    • View Profile
Re: BASS error -1
« Reply #3 on: January 25, 2010, 23:45:32 »
Danke, die Formulierung "Fehler beim Verbinden mit dem Streamingserver" habe ich gesucht, anhand derer konnte ich nachvollziehen, an welcher Stelle genau der Fehler auftritt. (Intern sind mehrere Schritte - jeweils mit BASS-Aufruf - notwendig, bis die Verbindung hergestellt ist.)

Leider ist "Fehler -1" nicht besonders aussagekräftig. Die BASS-Doku sagt dazu nur: "Some other mystery problem!"

Wärst du so nett, mir deine encoder.ini zu mailen? Das Passwort kannst du gerne vorher rauslöschen. info@mairlist.com.

Thomas S.

  • Newbie
  • *
  • Posts: 18
    • View Profile
    • Radio am Niederrhein
    • Email
Re: BASS error -1
« Reply #4 on: January 25, 2010, 23:51:55 »
ich such sie gerade die Datei, komischerweise ging der connect auf einem shoutcast problemlos, das hier ist ein icecast server....

gibt es einen Weg die ini schnell zu finde`n?

Torben

  • Administrator
  • Doktor mAirList
  • *****
  • Posts: 16287
    • View Profile
Re: BASS error -1
« Reply #5 on: January 26, 2010, 00:10:59 »
Den Konfigurationsordner findet man neuerdings leicht über den Menüpunkt "Erweitert -> Datenordner" im Konfigurationsprogramm :)

Ein guter Hinweis, dass es nur Icecast betrifft. Hättest du mal früher erwähnen können.

Lass mal das /-Zeichen am Anfang des Mountpoints weg, geht es dann? Das Passwort hast du hoffentlich ausgefüllt - auf dem Screenshot ist es leer.

Thomas S.

  • Newbie
  • *
  • Posts: 18
    • View Profile
    • Radio am Niederrhein
    • Email
Re: BASS error -1
« Reply #6 on: January 26, 2010, 00:23:49 »
lach ja das PW ist ausgefüllt, war nur für dich gelöscht  ;-)
Den Rest teste ich eben

Thomas S.

  • Newbie
  • *
  • Posts: 18
    • View Profile
    • Radio am Niederrhein
    • Email
Re: BASS error -1
« Reply #7 on: January 26, 2010, 00:44:15 »
ohne den / vor dem Mountpoint connected er einwandfrei auf dem Stream, habe aber einen doppler Effekt drin, d.h. ich höre das Lied mit einem Abstand von 1 sek nochmal, musss aber an den Einstellungen der Soundkarten dann liegen.

Das teste ich dann noch aus, ist eine Realtek AC 97

Torben

  • Administrator
  • Doktor mAirList
  • *****
  • Posts: 16287
    • View Profile
Re: BASS error -1
« Reply #8 on: January 26, 2010, 08:44:35 »
Ok, also lag es an dem /-Zeichen. Schon blöd, dass BASS da keine genauere Fehlermeldung zurückliefert...

Die Audio-Routinen sind identisch, egal ob Shoutcast oder Icecast. Ich denke auch, dass du die Soundkarte falsch eingestellt hast. Viel Erfolg!

Bernie

  • Regular
  • *
  • Posts: 351
    • View Profile
    • Email
Re: BASS error -1
« Reply #9 on: January 26, 2010, 13:39:22 »
Hast Du vielleicht im Encoder unter Soundkarten die Option "Wiedergabegerät" angklickt? Das hatte ich auch mit dem selben Effekt. Richtig ist die Einstellung "Keine lokale Wiedergabe" und bei Soundkarte für die Aufnahme die jeweils gültige Soundkarte einstellen.

Gruß
Bernie

Torben

  • Administrator
  • Doktor mAirList
  • *****
  • Posts: 16287
    • View Profile
Re: BASS error -1
« Reply #10 on: January 26, 2010, 13:44:45 »
Das kann man so pauschal nicht sagen. Lokale Wiedergabe ist schon in Ordnung, solange man die Kanäle ordentlich trennt. Also zum Beispiel nicht den Aufnahme-Kanal im Windows-Mixer auf die Summe gestellt hat (die natürlich die lokale Wiedergabe wieder enthält).

Bernie

  • Regular
  • *
  • Posts: 351
    • View Profile
    • Email
Re: BASS error -1
« Reply #11 on: January 26, 2010, 17:12:54 »
Klar Torben,

so gesehen hast Du natürlich recht. Ich bin dabei von meiner Konfiguration ausgegangen, die natürlich nicht allgemein gütig ist.  :-[

Thomas S.

  • Newbie
  • *
  • Posts: 18
    • View Profile
    • Radio am Niederrhein
    • Email
Re: BASS error -1
« Reply #12 on: January 26, 2010, 21:55:36 »
ich danke für die schnelle Hilfe,

Thomas

AntenneSH

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: BASS error -1
« Reply #13 on: April 01, 2015, 16:07:42 »
Moin,

wir kriegen ständig Bass Eror 1 rein... gibt es da jetzt schon eine Lösung?

den mit den Lösungen wie oben Beschrieben geht es bei uns nicht weg
« Last Edit: April 01, 2015, 17:39:57 by AntenneSH »